do i = 1, imt a(i) = b(i) + c(i) enddois more desirable than
a = b + c
Variables that are not state variables but are used in a similar manner should also follow this naming convention. Note that ai is not a good choice for a variable name.
real (kind=dbl_kind), dimension (imt_local,jmt_local) :: & aice ! concentration of ice &, vice ! volume per unit area of ice (m) &, vsno ! volume per unit area of snow (m)
integer (kind=int_kind) :: nyrp,mdayp,weekp ! previous year, day, week
Fresh(i,j) = Fresh(i,j) + (vsn(nc)*Rside*rhos $ + vin(nc)*Rside*rhoi)/dt
call comp_matrices ( rowflg, hin, Hmean, $ Gamm, HGamm, H2Gamm )
!----------------------------------------------------------------- ! initializations !-----------------------------------------------------------------while those indented to match the following pertinent code are "minor":
! compute aggregate ice state and open water area call aggregate